Truck Battery - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-18-2009, 10:26 PM   #1
Senior Member
 
Chester Taje's Avatar
 
Name: Ches
Trailer: 1992 Kustom Koach 17 FT
British Columbia
Posts: 4,897
If your truck battery was dead and you put charger on and charger shows 80% charge and charging rate is 13.3 volts. Should vehical start or is that still to low? The lights work and turn signals/Brake lights/Backup lights all work. Interior lights not working neither is radio.
__________________

__________________
Retired Underground Coal Miner.
Served in Canadian Army (1PPCLI)
Chester Taje is offline   Reply With Quote
Old 08-18-2009, 11:04 PM   #2
Moderator
 
Gina D.'s Avatar
 
Name: Gina D.
Trailer: '77 Leocraft 17 & Former Burro owner and fan!
West Coast USA
Posts: 9,016
Registry
check fuses. If the other stuff works, those should too, unless there is something specifically wrong with JUST those items.

Most likely... the fuse or fuses.
__________________

__________________
Gina D. is offline   Reply With Quote
Old 08-18-2009, 11:15 PM   #3
Senior Member
 
Chester Taje's Avatar
 
Name: Ches
Trailer: 1992 Kustom Koach 17 FT
British Columbia
Posts: 4,897
Quote:
check fuses. If the other stuff works, those should too, unless there is something specifically wrong with JUST those items.

Most likely... the fuse or fuses.
I plan on doing that in the morning.Its dark here now.
__________________
Retired Underground Coal Miner.
Served in Canadian Army (1PPCLI)
Chester Taje is offline   Reply With Quote
Old 08-18-2009, 11:42 PM   #4
Moderator
 
Gina D.'s Avatar
 
Name: Gina D.
Trailer: '77 Leocraft 17 & Former Burro owner and fan!
West Coast USA
Posts: 9,016
Registry
of course its dark.. your lights don't work!!!!

__________________
Gina D. is offline   Reply With Quote
Old 08-19-2009, 12:05 AM   #5
Junior Member
 
Albert F's Avatar
 
Trailer: 75 Honey Boler 13 ft
Posts: 3
Your battery terminals could also be corroded - that happened to me before. I had to take off the cables and wire brush the terminals then reattatch the cables and it was all good.
__________________
Albert F is offline   Reply With Quote
Old 08-19-2009, 12:22 AM   #6
Senior Member
 
Chester Taje's Avatar
 
Name: Ches
Trailer: 1992 Kustom Koach 17 FT
British Columbia
Posts: 4,897
Gina you kill me

Albert the teminals a like brand new. I have read to manual front to back. I am hoping that it is the ignition fuse. The radio does not work/the interior lights and windows won,t roll up or down, Everything else is good to go except it won,t start. Not even a grunt when i try starting.

It run this morning.
__________________
Retired Underground Coal Miner.
Served in Canadian Army (1PPCLI)
Chester Taje is offline   Reply With Quote
Old 08-19-2009, 11:31 AM   #7
Moderator
 
Gina D.'s Avatar
 
Name: Gina D.
Trailer: '77 Leocraft 17 & Former Burro owner and fan!
West Coast USA
Posts: 9,016
Registry
bad ignition switch?

I had one you had to do a little dance around, chanting a mantra, while the car was parked due north.. and after several delicate tries, you could get it to catch.

I don't recall it being expensive to fix, but that was during the medieval times... the 70s.
__________________
Gina D. is offline   Reply With Quote
Old 08-19-2009, 11:48 AM   #8
Senior Member
 
Chester Taje's Avatar
 
Name: Ches
Trailer: 1992 Kustom Koach 17 FT
British Columbia
Posts: 4,897
Finally got it going. It was the instrument panel fuse. 15Amp one.

Thanks all for giving me your feedback.
__________________

__________________
Retired Underground Coal Miner.
Served in Canadian Army (1PPCLI)
Chester Taje is offline   Reply With Quote
Reply

Tags
battery


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck Slide Pete Dumbleton General Chat 0 04-13-2008 02:33 PM
Hooking up boler battery to Tug battery Andy H Problem Solving | Owners Helping Owners 3 08-02-2007 01:59 PM
Too Much Truck? Pete Dumbleton General Chat 6 02-06-2007 11:15 AM
Truck Stop Paddy Morris Jokes, Stories & Tall Tales 2 07-23-2006 08:26 AM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.