AC issue - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-13-2018, 05:57 PM   #1
Junior Member
 
Name: Aaron
Trailer: Scamp
Texas
Posts: 5
AC issue

We have a 2000 19. The air conditioner is now giving us issues. We have noticed it's not as cold as our previous trailer ('2013 13) but now it has stopped blowing the cold air altogether. When we turn on the AC the compressor kicks in but the blower doesn't. When I take the cover off and give it a spin it'll keep spinning and work as usual. What should we do? I'm happy to replace parts but is an 18 year old ac worth fixing? Help!
__________________

TXScamper is offline   Reply With Quote
Old 07-13-2018, 07:38 PM   #2
Senior Member
 
Name: Jack L
Trailer: Bigfoot B-17 CB
Washington
Posts: 1,336
I would clean the fan blades and pot a drop of oil in the fan shaft.
__________________

Jack L is online now   Reply With Quote
Old 07-14-2018, 07:08 AM   #3
Senior Member
 
Dan Meyer's Avatar
 
Name: Dan
Trailer: Scamp
Minnesota
Posts: 574
Quote:
Originally Posted by Jack L View Post
I would clean the fan blades and pot a drop of oil in the fan shaft.

If the above doesn't fix the problem, replace the motor run capacitor, for a lot less money and time than a new air conditioner will cost.



--Dan Meyer
Dan Meyer is offline   Reply With Quote
Old 07-14-2018, 07:51 AM   #4
Senior Member
 
floyd's Avatar
 
Name: Floyd
Trailer: 2004 13 ft Scamp Custom Deluxe
IllAnnoy
Posts: 6,629
Registry
Odds are you have a Coleman MiniMach?...
If so, its worth the effort to try and repair,

Good advice in above posts.

It is a good A/C and only 7200BTU.
floyd is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cold Cathode Issue Greg A Problem Solving | Owners Helping Owners 4 05-31-2007 11:25 PM
carpeting issue... Rarebird Problem Solving | Owners Helping Owners 2 12-04-2006 05:34 PM
Battery Issue (?) Tirah Problem Solving | Owners Helping Owners 11 07-21-2006 12:08 PM
Hatch issue Scamp 13 footer jefflynne Problem Solving | Owners Helping Owners 7 06-05-2006 08:52 PM
Scamp wiring issue llollio Problem Solving | Owners Helping Owners 9 05-06-2006 04:00 PM

» Trailer Showcase

Bella

Just jenn

Burro

Alan C.
» Upcoming Events
No events scheduled in
the next 465 days.
» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.