allanson d30-bra-e - Fiberglass RV

Thread Tools Search this Thread Display Modes
Old 08-06-2016, 09:07 PM   #1
Junior Member
Name: Richard
Trailer: Bigfoot 19'
British Columbia
Posts: 27
allanson d30-bra-e

We have a D30-BRA-E in our new to us trailer. I'm finding that when our trailer is plugged in there is 8.85v going to the battery. I didn't think these units were chargers too and that voltage seems to be low to charge a battery.

Are these chargers too. Is the voltage correct? Also it seems some appliance only work when plugged in. Ie Tank monitor, Battery check, Furnace. When testing when on battery power the battery is fully charged.

Thoughts , observations and ideas on moving forward are appreciated.

evenweight is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:51 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.