Cold Cathode Issue - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-30-2007, 11:52 PM   #1
Senior Member
 
Greg A's Avatar
 
Name: Greg
Trailer: 2015 Escape 19
Arizona
Posts: 1,828
I'm not sure if my cold cathode tubes are defective or this is normal. The converter piece that I installed inside the overhead get's extremely hot to the touch. In fact if you touched it for long it would burn you. If anything were to lay on it or touch it that was flammable it definitely would start a fire. Is this normal or are mine defective??
__________________

__________________
Owner:
Fiberglass-RV-4Sale.com
Scamp Owners International
2015 Escape 19 & 1997 Scamp 19
Greg A is offline   Reply With Quote
Old 05-31-2007, 12:00 AM   #2
Moderator
 
Gina D.'s Avatar
 
Name: Gina D.
Trailer: '77 Leocraft 17 & Former Burro owner and fan!
West Coast USA
Posts: 9,016
Registry
The tubes? Or the invertor?

The tubes will get toasty, yes, but I can touch mine easily.

The invertor barely gets warmish.
__________________

__________________
Gina D. is offline   Reply With Quote
Old 05-31-2007, 12:04 AM   #3
Senior Member
 
Greg A's Avatar
 
Name: Greg
Trailer: 2015 Escape 19
Arizona
Posts: 1,828
The inverter gets blazing hot. Tubes are warmish....
__________________
Owner:
Fiberglass-RV-4Sale.com
Scamp Owners International
2015 Escape 19 & 1997 Scamp 19
Greg A is offline   Reply With Quote
Old 05-31-2007, 08:47 PM   #4
Junior Member
 
Sean Janusheske's Avatar
 
Trailer: 96 Casita 17 ft Freedom Deluxe
Posts: 5
That's not good. Confirm your input voltage. I figure if it's too high your ccl inverter will fry.
If your input voltage is 12-13.8vdc there should be no problem with overheating.
All my ccl inverters are just warm, never hot even when input is at 13.8vdc.

Also ensure the vent holes are clear and not covered.

Sean
__________________
Sean Janusheske is offline   Reply With Quote
Old 06-01-2007, 12:25 AM   #5
Senior Member
 
Greg A's Avatar
 
Name: Greg
Trailer: 2015 Escape 19
Arizona
Posts: 1,828
Thanks Sean, I'll slap a voltage check on it and see. Don't see any vent holes just a small metal rectangle which I have screwed down to the overhead cabinet then the wires go down to the tubes.
__________________
Owner:
Fiberglass-RV-4Sale.com
Scamp Owners International
2015 Escape 19 & 1997 Scamp 19
Greg A is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
solar issue cyndi H Problem Solving | Owners Helping Owners 31 08-21-2008 11:19 AM
Cold cathode fluorescent lights 12 volt Mike Taylor Modifications, Alterations and Updates 60 07-24-2008 03:21 PM
anyone installed cold cathode lights al gilliland Problem Solving | Owners Helping Owners 9 06-06-2007 07:19 PM
Cold Cathode and flickering lights al gilliland Problem Solving | Owners Helping Owners 7 05-10-2007 05:09 PM
Battery Issue (?) Tirah Problem Solving | Owners Helping Owners 11 07-21-2006 01:08 PM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.