Dead Battery: Please help! - Page 2 - Fiberglass RV

Thread Tools Search this Thread Display Modes
Old 07-01-2016, 09:19 AM   #15
Name: Gerry
Trailer: Triple E
British Columbia
Posts: 45
Did you have your fridge operating off either propane or 120 volts? Just a shot, but many newer fridges have a heater element in the frame of the freezer compartment. This element is operating all of the time the fridge is running, unless it is switched off. The switch is in the frame above the freezer compartment door.

Gerry Kiernan is offline   Reply With Quote
Old 07-01-2016, 09:43 AM   #16
Junior Member
Name: Dennis
Trailer: 16' Scamp
Posts: 11

Unless you actually ENJOY "the hunt", just take your trailer to a good RV shop and pay them to check this out. After all, you've already spent a fairly large bill on a NEW battery. Get it over with, and learn from what they tell you.

dkas is offline   Reply With Quote
Old 07-01-2016, 09:46 AM   #17
Julie and Jose's Avatar
Name: Julie
Trailer: Scamp
Posts: 35
We didn't use the fridge. We still can't get it to work on propane. LOL. It used to light but not get cold. We cleaned the jet and now it doesn't even light! Oy vey.

Don't have a freezer either.
Julie and Jose is offline   Reply With Quote
Old 07-01-2016, 10:28 AM   #18
Senior Member
Trailer: 2002 19 ft Scamp 19 ft 5th Wheel
Posts: 2,785
Send a message via Yahoo to Darwin Maring
Go to Advance Auto where they do FREE battery testing and get it tested.
Darwin Maring is offline   Reply With Quote
Old 07-01-2016, 10:42 AM   #19
Junior Member
Name: Larry
Trailer: T@B
Posts: 6
Originally Posted by Julie and Jose View Post
Thanks all for helping.

When we connect the car to the battery with the engine running it reads 13.5. Drops when the engine is turned off and still connected.

So...could this be a bad converter?
When you check the battery with a charge source connected (either the tow vehicle or shore power/garage), your reading will reflect the voltage being SENT TO the battery, NOT the actual charge state of the battery. Only way to accurately check the charge state of the battery is to disconnect all cables and check with a meter at the posts.

This, of course, means that the readings taken while connected to a running tow vehicle and those taken while disconnected from any charge source SHOULD be different.
2013 T@B
Larry G. is offline   Reply With Quote
Old 07-01-2016, 10:44 AM   #20
Julie and Jose's Avatar
Name: Julie
Trailer: Scamp
Posts: 35
Uh no, the converter was NOT plugged in!

Well, it looks like we might have found problem #1 thanks to Carl Pa. The converter plugged had wormed its way partially out of the outlet, probably due to all the bumps on the road during our extended trip. It is now seated firmly in the outlet and we have 12v lights when plugged into shore power. Yay! The converter is still working...maybe....

We think we may still have a drain on the battery, though. So we will charge the battery and then disconnect from shore power to see what happens.

And yes, we have a multimeter. And yes, we know the battery is good. (Took the old one to the battery store to be tested. It was on its last legs. Replaced with a shiny new one.)

Appreciate all the help! We learn new things every day thanks to this great community.
Julie and Jose is offline   Reply With Quote
Old 07-01-2016, 12:30 PM   #21
Senior Member
Carl Pa's Avatar
Name: Carl
Trailer: 2014 16 scamp side dinette/Rav4 V6 Tow pkg.
Posts: 378
Great, I now check plug when I reach destination and when I get home. Good luck. Carl

Carl Pa is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
battery dead follow up crowwing Problem Solving | Owners Helping Owners 0 09-28-2015 06:47 PM
Scamp tail liters and dead battery rmartin057 Problem Solving | Owners Helping Owners 3 06-26-2015 02:13 PM
Dead Battery After Towing Erik in Wisco Electrical | Charging, Systems, Solar and Generators 12 11-15-2013 08:44 PM
Solar Trickle Charger & Dead Battery V'sGlassSleeper Problem Solving | Owners Helping Owners 11 03-19-2010 07:29 PM
Help dead battery & still no lights plugged in- Mark J Problem Solving | Owners Helping Owners 8 12-09-2009 04:15 AM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:21 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.