Escape A/C problem - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-20-2010, 03:42 AM   #1
Senior Member
 
Anne H's Avatar
 
Name: Anne
Trailer: Escape 17 ft 2006 / 2005 Honda Pilot
Oregon
Posts: 465
Registry
Escape A/C problem

Well, I thought I would clean out my trailer after a recent trip - but it was over 90 degrees out But then I thought, "I have A/C" - and this would be a great opportunity to use it - since I had it put in 2 years ago, I think I've turned it on a couple of times to test it - but never actually used it.

Alas - the fan runs but the cooling did not happen. I tried the 'Test' and 'Reset' buttons (usually I only have to do that after the trailer battery has been unhooked for the winter) - but that didn't help.
The filter is sparkling clean.

I checked Curtis Trailers and another place they recommended to look at it but no one seems to want to look at a unit that isn't roof top mounted. They seem to think that it might be freon-based vs ammonia-based and, in any case, Frigidairre may have recalled it (???).

I can't get anyone to look at it.

Any ideas??
__________________

__________________
Anne H and Fay Wray, the cat | Portland, OR
en Plein Air (2016 19' Escape; 2016 Honda Pilot )
http://rightbrainrightlane.blogspot.com/
Anne H is offline   Reply With Quote
Old 08-20-2010, 07:51 PM   #2
Member
 
FRANK MOLIS's Avatar
 
Trailer: 1980 (Circa) 13 ft Scamp (A WORK IN PROGRESS)
Posts: 52
Registry
What kind of AC is it? How long did you let it run? On some units, the compressor will not start until after the fan has been running for a few minutes.
__________________

__________________
FRANK MOLIS is offline   Reply With Quote
Old 08-20-2010, 08:00 PM   #3
Senior Member
 
Anne H's Avatar
 
Name: Anne
Trailer: Escape 17 ft 2006 / 2005 Honda Pilot
Oregon
Posts: 465
Registry
Frigidaire - installed by the Escape folks in a cabinet over the fridge. I know it worked when I picked it up.

I let it run for over an hour - and then at least 15 minutes after I tried the Test/Reset button.


Quote:
Originally Posted by FRANK MOLIS View Post
What kind of AC is it? How long did you let it run? On some units, the compressor will not start until after the fan has been running for a few minutes.
__________________
Anne H and Fay Wray, the cat | Portland, OR
en Plein Air (2016 19' Escape; 2016 Honda Pilot )
http://rightbrainrightlane.blogspot.com/
Anne H is offline   Reply With Quote
Reply

Tags
escape


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Escape Converter Problem Penney H. & Mike E. Problem Solving | Owners Helping Owners 1 06-20-2010 09:44 AM
problem with PC Legacy Posts Jokes, Stories & Tall Tales 16 02-02-2003 09:15 PM
New AC problem Legacy Posts Problem Solving | Owners Helping Owners 7 11-10-2002 11:22 PM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.