Frustrating...ready to leave....no lights! - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-01-2012, 05:54 AM   #1
Member
 
Name: Tom
Trailer: 1999 Casita Spirit Deluxe
South Carolina
Posts: 51
Registry
Frustrating...ready to leave....no lights!

I've been pulling our Casita for almost 6 months with no issues. Had 7 pin receptacle installed on our 97 Montero when we bought the the trailer. Always plug in and go. Last night I got home from work late....packed....hooked up, ready to head out for weekend of camping....no lights whatsoever on the trailer (no issues on TV). I understand from reading other posts that there are no fuses in the trailer. Once it gets light this morning I'm going to see if I can find the fuses....

If I'm unsuccessful....what's next step? Is this the kind of thing u-haul would be able to troubleshoot/fix? Or as simple as going by auto zone? It's Saturday...not many service places open.....

Arghhhh.....




.
__________________

__________________
GerthT is offline   Reply With Quote
Old 12-01-2012, 06:06 AM   #2
Senior Member
 
Name: Steve
Trailer: Bigfoot, Trillium, Scamp 5th Wheel
Spokane Wa. and Las Vegas, Nv.
Posts: 1,312
Registry
You might have some corrosion in your 7 pin connector. Pick up a can of contact cleaner, spray both ends liberally and try it again.
__________________

__________________
Steve Hammel is offline   Reply With Quote
Old 12-01-2012, 06:28 AM   #3
Senior Member
 
Name: bob
Trailer: 1984 u-haul ct13; 1996 Casita 17 Spirit Deluxe; 1946 Modernistic teardrop
New York
Posts: 4,333
Sometimes just by connecting & disconnecting the plug several times will get you a good connection. The female parts of a plug can be cleaned with a 22 cal. Rifle cleaning brush.
__________________
mary and bob is offline   Reply With Quote
Old 12-01-2012, 06:30 AM   #4
Senior Member
 
Donna D.'s Avatar
 
Name: Donna D
Trailer: Escape 5.0 TA, 2014
Oregon
Posts: 24,433
Contact cleaner should be in everyone's travel tool box. Not having lights doesn't just happen at home. Tom, even though you have lights on the TV, check all the fuses.
__________________
Donna D.
Ten Forward - 2014 Escape 5.0 TA
Double Yolk - 1988 16' Scamp Deluxe
Donna D. is online now   Reply With Quote
Old 12-01-2012, 09:04 AM   #5
Member
 
Name: Tom
Trailer: 1999 Casita Spirit Deluxe
South Carolina
Posts: 51
Registry
Smile

Tried the contact cleaner...no luck. Found where the guy who installed my trailer wiring hooked into the battery and found 20A fuse. Pulled it out and tested it. Tested fine. Put it back in, then started looking for ground on the trailer. See where the wire goes into the front of the camper, but not sure where that goes.

Anyway, just for the heck of it, I turned on the TV lights....voila! They work! I did notice the front curbside marker light is not illuminating. Weird. Not sure what happened?

Anyway, we're going to head out....I'll do some more research after we get to the campsite. I have my computer and Arizona Eileen's CD..... may try to change that bulb out (if I can figure out how to get the light cover off).

Thanks for all the feedback, my virtual friends! Happy camping!
__________________
GerthT is offline   Reply With Quote
Old 12-01-2012, 09:12 AM   #6
Senior Member
 
Donna D.'s Avatar
 
Name: Donna D
Trailer: Escape 5.0 TA, 2014
Oregon
Posts: 24,433
Safe travels Tom!
__________________
Donna D.
Ten Forward - 2014 Escape 5.0 TA
Double Yolk - 1988 16' Scamp Deluxe
Donna D. is online now   Reply With Quote
Old 12-01-2012, 12:06 PM   #7
Senior Member
 
Name: Kevin
Trailer: 28' Bigfoot Silver Cloud
Oak Park, IL
Posts: 1,115
Send a message via Yahoo to Kevin A
Ah, the continuing mysteries of the light gremlins.
__________________
Kevin A is offline   Reply With Quote
Old 12-01-2012, 12:51 PM   #8
Senior Member
 
Thomas G.'s Avatar
 
Name: Kinga DeRode
Trailer: For Sale Or Rent
Rooms to Let 50 Cents
Posts: 5,103
Quote:
Originally Posted by Kevin A View Post
Ah, the continuing mysteries of the light gremlins.

My money is on a bad ground. OP may have jiggled the coupler enough to get a better ground to TV.
__________________
UHaul and Burro owners, join the UHaul Campers on Facebook. https://www.facebook.com/groups/529276933859491/
Thomas G. is online now   Reply With Quote
Old 12-01-2012, 01:19 PM   #9
Senior Member
 
Jared J's Avatar
 
Name: Jared
Trailer: 1984 19' scamp
Kansas
Posts: 1,610
Quote:
Originally Posted by Thomas G. View Post

My money is on a bad ground. OP may have jiggled the coupler enough to get a better ground to TV.
Yep. In that case, I have a 30' wire with alligator clips on it. I go from the tv battery to the trailer ground past the connector. Quick way to isolate half the system.
__________________
Jared J is offline   Reply With Quote
Old 12-01-2012, 04:07 PM   #10
Senior Member
 
Francesca Knowles's Avatar
 
Name: Francesca Knowles
Trailer: '78 Trillium 4500
Jefferson County, Washington State, U.S.A.
Posts: 4,543
Registry
Quote:
Originally Posted by GerthT View Post

Anyway, just for the heck of it, I turned on the TV lights....voila!


Please tell us that you tried turning on the tow vehicle lights the first time, too...

Francesca ...I think...
__________________
.................................
Propane Facts vs. Fiction:. Click here
Tow Limit Calculator: Click here
Francesca Knowles is offline   Reply With Quote
Old 12-01-2012, 05:59 PM   #11
Senior Member
 
Name: Darwin
Trailer: 2002 19 ft Scamp 19 ft 5th Wheel
Posts: 3,030
Send a message via Yahoo to Darwin Maring
The trailer hitch and TV ball makes a ground also when hitched up however it may be iffy at times. (On/Off)
__________________

__________________
Darwin Maring is offline   Reply With Quote
Reply

Tags
lights


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Lights, Turn signal lights, marker lights, oh my! glamourpets Problem Solving | Owners Helping Owners 19 01-03-2013 10:10 AM
Do you leave anything in the egg when it is not in use? Elizabeth TXorMT General Chat 11 01-29-2010 09:47 PM
WE LEAVE D Tharp General Chat 5 02-03-2007 07:05 PM

» Trailer Showcase

Bebe

MMiller

75 Boler

Randy D.
» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.