Furnace not lighting - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-11-2008, 02:47 PM   #1
Senior Member
 
Ami P's Avatar
 
Trailer: U-Haul VT16 1985
Posts: 110
The Suburban furnace in my UHaul does everything right except light. Thermostat on, blower comes on, I see the sparks on the ignitor, there is LP gas at the valve - still no flame in the combustion chamber. In the manual I read that c. chambers are finicky, subject to corrosion, one must have the correct mix of air and propane, etc. Has anyone succeeded in replacing the combustion chamber in their furnace?
__________________

__________________
Ami P is offline   Reply With Quote
Old 07-11-2008, 04:50 PM   #2
Senior Member
 
Name: Darwin
Trailer: 2002 19 ft Scamp 19 ft 5th Wheel
Posts: 3,030
Send a message via Yahoo to Darwin Maring
Mine got water in it and I opened it (Plate on the front comes off) and used a towell to soak up the water. All was well after that.

B sure to NOT ruin the gasket between the plate and the furnace. Get some hi temp sealer B4 you take the plate off just in case you break the gasket.

U can also take the burner out and clean off the rust and open the holes.
__________________

__________________
Darwin Maring is offline   Reply With Quote
Old 07-11-2008, 05:31 PM   #3
Senior Member
 
paulw's Avatar
 
Trailer: Escape
Posts: 361
Registry
HI Ami,
I had trouble getting mine to light the first time.
I lit the stove and ran it for a bit, then the furnace fired right up .
paulw is offline   Reply With Quote
Old 07-11-2008, 08:10 PM   #4
Senior Member
 
Name: Darwin
Trailer: 2002 19 ft Scamp 19 ft 5th Wheel
Posts: 3,030
Send a message via Yahoo to Darwin Maring
Paul & Norma are absolutely right.

You must always purg the air out of the lines first and I use the cook top just as they do to accomplish that.
__________________
Darwin Maring is offline   Reply With Quote
Old 07-11-2008, 10:20 PM   #5
Senior Member
 
Ami P's Avatar
 
Trailer: U-Haul VT16 1985
Posts: 110
1. I will try lighting/running the stove first.
2. I cannot access the burner because the holding screws are so rusted in that I broke the tip of the screwdriver in the attempt.
__________________
Ami P is offline   Reply With Quote
Reply

Tags
furnace


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
L.E.D. Lighting Glen Aldridge Classified Archives 4 03-26-2011 06:32 PM
lighting christineb Problem Solving | Owners Helping Owners 5 07-26-2010 05:41 PM
Lighting pilot of Duo-Therm 11HU furnace Barrie Bochoff Problem Solving | Owners Helping Owners 3 07-16-2010 07:06 PM
Led lighting JIMZ Problem Solving | Owners Helping Owners 48 01-19-2006 07:31 PM
LED lighting Legacy Posts Modifications, Alterations and Updates 50 07-22-2003 11:25 PM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.