my furnace doesn't kick in - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-05-2010, 11:10 AM   #1
Senior Member
 
Trailer: 2009 13 ft Trillium (USA)
Posts: 151
Usually when I click the thermostat to the ON position and the trailer is a bit cold, the fan will immediately come on....but the heat will slowly follow. Now, with plenty of power available from my home, I click the thermostat on and nothing. Should I check the fuses? Could it be anything else? Thanks, Lloyd
__________________

__________________
lloyd cicetti is offline   Reply With Quote
Old 04-05-2010, 03:57 PM   #2
Senior Member
 
Trailer: 17.5 ft and 25 ft FB Bigfoot
Posts: 194
It could be a number of things. Start with the easiest and progress to the more difficult. Yes fuses and breakers should be checked first. Use a volt meter at the fan to see if the fan hasn't burnt out. Check the thermostat control so see if broken, wire corroded, loose wire. You can also use a volt meter at the therostat although I don't know what voltage it should read. After that I'm afraid I'd have to call my friendly RV technician.
__________________

__________________
Tamid is offline   Reply With Quote
Old 04-05-2010, 09:06 PM   #3
Member
 
Doug P.'s Avatar
 
Name: Doug
Trailer: Escape 5.0TA
Southern Alberta
Posts: 72
Some furnaces have a reset button, its normally near the front so as to be easily accessed.
Might be an easy fix.....
__________________
Doug P. is offline   Reply With Quote
Old 04-05-2010, 09:23 PM   #4
Senior Member
 
Donna D.'s Avatar
 
Name: Donna D
Trailer: Escape 5.0 TA, 2014
Oregon
Posts: 24,433
Quote:
It could be a number of things. Start with the easiest and progress to the more difficult.
Propane turned on???
__________________
Donna D.
Ten Forward - 2014 Escape 5.0 TA
Double Yolk - 1988 16' Scamp Deluxe
Donna D. is offline   Reply With Quote
Old 04-05-2010, 10:44 PM   #5
Senior Member
 
Harry Young's Avatar
 
Trailer: 1971 Astro (ie. Campster/Hunter I)
Posts: 437
Send a message via MSN to Harry Young Send a message via Yahoo to Harry Young
Post

lloyd

Make and model of furnace would really help.

Harry
__________________
Harry Young is offline   Reply With Quote
Old 04-05-2010, 11:02 PM   #6
Senior Member
 
Trailer: 2009 13 ft Trillium (USA)
Posts: 151
Quote:
lloyd

Make and model of furnace would really help.

Harry
Harry, I think it's an Atwood...but I will get back to you with Model No. Thanks, Lloyd
__________________

__________________
lloyd cicetti is offline   Reply With Quote
Reply

Tags
furnace


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood furnace new on Trillium..won't kick on...fuses fine.... lloyd cicetti General Chat 15 04-12-2010 09:21 PM
Furnace doesn't start ThomasE Problem Solving | Owners Helping Owners 16 10-13-2009 02:22 PM
Side Kick Trailers Will O'Crotty General Chat 9 03-18-2008 12:03 PM
The Louisiana Three Kick Rule Legacy Posts Jokes, Stories & Tall Tales 0 03-30-2003 09:00 AM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.