repairing Uhaul furnace - Page 2 - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-09-2010, 09:49 PM   #15
Senior Member
 
Bridget T's Avatar
 
Trailer: 1985 U-Haul CT13 ft ('The Mothball')
Posts: 102
Bruce,
From my minimal knowledge of our furnaces I wonder if it is the dinosaur board. This is the thing I show myself changing in the pictures in this post. My furnace did the same thing - would light for a few seconds and then the flame would die out. It seems like the board controls the continuation of the flame, among other things. Someone knowlegable on this, please pipe in.
While I just took the board out of Karen's furnace (and the verdict is still out as to whether it is working for me - it could be the board and not the thermostat that is malfunctioning and keeping it on all the time - will try to work on it during this long weekend - the real Thanksgiving ) you can also buy a new board. They are called dinosaur boards, and I might be ordering one, we'll see.

Ignitor Board Index page


Quote:
Originally Posted by Bruce Thomas View Post
Matt (or anyone)...when I picked up my uhaul last year the furnace wouldnt light and then it did after a few days.i thought it had something to do with my charging the battery but I guess not.....now mine cycles through like its gonna light but doesnt.......any idea's? and can I take it out and bring it to a heating and ac joint or will they be lost?......thanks bruce
__________________

__________________
Bridget T is offline   Reply With Quote
Old 10-10-2010, 07:46 AM   #16
Senior Member
 
Bruce Thomas's Avatar
 
Name: Bruce T
Trailer: Compact jr
Indiana
Posts: 721
Registry
Matt....yes the fan runs and the thermostat works...Bridgett.thanks for the link..I guess i better get diagnosing and get whats needed..it was cold here in that thing friday!.......Bruce
__________________

__________________
Bruce Thomas is offline   Reply With Quote
Old 10-13-2010, 04:38 PM   #17
Member
 
Trailer: Trillium 4500
Posts: 50
flame rod

Quote:
Originally Posted by Bruce Thomas View Post
Matt (or anyone)...when I picked up my uhaul last year the furnace wouldnt light and then it did after a few days.i thought it had something to do with my charging the battery but I guess not.....now mine cycles through like its gonna light but doesnt.......any idea's? and can I take it out and bring it to a heating and ac joint or will they be lost?......thanks bruce
sounds like the board does not recognize the flame has lit. Solution for this is to clean the flame rod with 000 steel wool and make sure it is situated in the flame. The flame retification system requires good grounds so you also want to check the connection to the rod, the wire, and the connection to the board to ensure they are clean, snug and sound.

It's critical that polarity of power source is correct.
__________________
nick c is offline   Reply With Quote
Old 10-15-2010, 01:28 PM   #18
Senior Member
 
Bruce Thomas's Avatar
 
Name: Bruce T
Trailer: Compact jr
Indiana
Posts: 721
Registry
there's no flame to recognize...it doesnt light ....at times i see the sparking where its trying to light something and thats it now...Bruce
__________________
Bruce Thomas is offline   Reply With Quote
Old 10-15-2010, 08:16 PM   #19
Member
 
Trailer: Trillium 4500
Posts: 50
sparking

Quote:
Originally Posted by Bruce Thomas View Post
there's no flame to recognize...it doesnt light ....at times i see the sparking where its trying to light something and thats it now...Bruce
when I picked up my uhaul last year the furnace wouldnt light and then it did after a few days.

As you are able to view sparking and no flame, and as it did work last year after trying multiple times, I would purge the gas line to the furnace. You can follow the line back to the next appliance nearest the furnace, light that appliance and fire for a minute, then cycle the furnace a few times till it lights. OR loosen the gas line at the gas valve and purge gas to atmosphere. (Only talking a little ...10 sec.) Ventilate well, no nearby sources of ignition. (against gas code, considered not safe practice with out use of approved purge burner) (propane heavier than air will want to fall out open door.)

If your hearing is good, you should be able to hear gas flowing/hissing out at burner as you view the sparking. If not flowing, burner oriface may be obstructed and require cleaning. ie: spider webbing. Hope that helps...
__________________

__________________
nick c is offline   Reply With Quote
Reply

Tags
furnace, u-haul, uhaul


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Repairing My Water Leak Joseph Domingos Care and Feeding of Molded Fiberglass Trailers 4 08-31-2009 10:11 AM
Repairing from the wind storm Lainey General Chat 7 10-26-2008 01:30 PM
repairing boler shell brian s Problem Solving | Owners Helping Owners 2 07-11-2006 12:18 AM
Repairing the gelcoat Legacy Posts Care and Feeding of Molded Fiberglass Trailers 16 08-07-2003 03:56 PM
repairing cracks Legacy Posts Care and Feeding of Molded Fiberglass Trailers 30 02-27-2003 04:00 PM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.