Scamp No Brake Lights/Turn Signals - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-27-2016, 12:42 PM   #1
Junior Member
 
Name: Jim
Trailer: 13' Scamp
Kansas
Posts: 23
Scamp No Brake Lights/Turn Signals

Hi, brand new (to me) Scamp owner.
It's a 1981 13'. I have a 4 pin connection from my Honda Element that I've used with no problem renting a trailer at UHaul and having working turn signals and brake lights.
With my Scamp, the running lights work fine when the car lights are on, but not the brake lights or turn signals.
Ideas?
Thanks
__________________

__________________
jzaman1 is offline   Reply With Quote
Old 07-27-2016, 12:55 PM   #2
Senior Member
 
Byron Kinnaman's Avatar
 
Name: Byron
Trailer: 2006 Scamp 13' towed with a 2005 Dodge Dakota 4.7l Magnum W/full tow package (over kill)
Oregon
Posts: 5,920
Registry
Take the trailer to an RV repair or trailer store and let them that knows what they're doing fix it.
__________________

__________________
Byron & Anne enjoying the everyday Saturday thing.
Byron Kinnaman is offline   Reply With Quote
Old 07-27-2016, 03:01 PM   #3
Moderator
 
Jim Bennett's Avatar
 
Name: Jim
Trailer: 2017 Escape 5.0 TA
Alberta
Posts: 4,243
Registry
Hi Jim, welcome to the site. Congrats on getting a new to you trailer.

It could certainly be a few different things causing your light issue.

Do the tail lights and marker lights both come on fine. If not I would start with the bulbs to see that they are good. Also check the ground to the fixtures.


If the tail lights work, it is more likely something amiss with the wiring, something you would need to wring out right from the vehicle connection. Using a meter you could check continuity from the plug to the light itself, and if there is nothing you then need to trace your way back.

I am sure others might have some more insight too.

Failing that, a trip to a shop that can check it out might be in order.
__________________
2017 Escape 5.0 TA (January 26)
2015 Ford F150 Lariat 3.5L EcoBoost
2009 Escape 19 (previous)
“Most folks are about as happy as they make up their minds to be.” — Abraham Lincoln
Jim Bennett is offline   Reply With Quote
Old 07-28-2016, 08:39 AM   #4
Junior Member
 
Name: Jim
Trailer: 13' Scamp
Kansas
Posts: 23
Thanks

Thanks for the advice. Electrical work has never been my strong suit. Sounds like a trip to the shop may be in order.
__________________
jzaman1 is offline   Reply With Quote
Old 07-28-2016, 10:18 AM   #5
Senior Member
 
Name: Roger
Trailer: U Hall VT
Michigan
Posts: 394
Registry
Sounds like bad connection at bulb take it out and put penetrating oil on it and put it back in, see if that works for you.
__________________
Roger Kimble is offline   Reply With Quote
Old 07-29-2016, 08:27 AM   #6
Member
 
Name: Duane
Trailer: 1978 Burro
Michigan
Posts: 73
4 way trailer plug tester

Quote:
Originally Posted by jzaman1 View Post
Hi, brand new (to me) Scamp owner.
It's a 1981 13'. I have a 4 pin connection from my Honda Element that I've used with no problem renting a trailer at UHaul and having working turn signals and brake lights.
With my Scamp, the running lights work fine when the car lights are on, but not the brake lights or turn signals.
Ideas?
Thanks
This thing doesn't put much of a load on the circuits but can be useful in a pinch.

Four-Way Trailer Light Tester
__________________
DuaneQ is offline   Reply With Quote
Old 07-29-2016, 12:24 PM   #7
Junior Member
 
Name: Jim
Trailer: 13' Scamp
Kansas
Posts: 23
Great idea

Thanks
__________________

__________________
jzaman1 is offline   Reply With Quote
Reply

Tags
light, lights, scamp


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Lights/Turn Signals Not Working (Blowing Fuse) DeanCHS1980 Electrical | Charging, Systems, Solar and Generators 12 05-04-2016 03:13 PM
Help with wiring to tail lights and side signals Trillium-Pettis Electrical | Charging, Systems, Solar and Generators 18 06-26-2015 04:15 PM
How do you make turn signals work on side lights? Rusty99 Electrical | Charging, Systems, Solar and Generators 13 05-29-2014 02:10 PM
Brake Lights, Turn signal lights, marker lights, oh my! glamourpets Problem Solving | Owners Helping Owners 19 01-03-2013 10:10 AM
Using side marker lights as turn signals al gilliland Care and Feeding of Molded Fiberglass Trailers 30 08-14-2009 05:53 PM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.