Suburban heater - Gas valve question - Fiberglass RV

Thread Tools Search this Thread Display Modes
Old 02-15-2010, 08:56 PM   #1
Junior Member
Trailer: 95 13 ft Scamp
Posts: 1
1995 scamp 13'... Ive got power to the 2 gas valves but no gas is passing through them. I unhooked the gas line, ran 12v to the valves, and hooked up some 5/8" heater hose to the gas inlet, and blew in the hose... Couldnt push any air through the valves either. Both valve "click" on when 12v is applied, but they must not be opening.

Could the valves be bad? Could there be blockage on the heater side of the valves, causing this problem? Thanks

Todd Russ is offline   Reply With Quote
Old 02-17-2010, 08:10 AM   #2
Senior Member
Harry Young's Avatar
Trailer: 1971 Astro (ie. Campster/Hunter I)
Posts: 436
Send a message via MSN to Harry Young Send a message via Yahoo to Harry Young


I am going to guess that you have an NT series heater, the valves need to be tested individually, when moisture gets in one valve it often corrodes that one shut, (water reacts with the aluminum body) it does require pressure to operate them as well properly. (10 inches of water column)

If the doc center is up... I sent the complete service manual there for all to use, it does cover the whole testing protocol, if the Doc center still has the flu I can send the manual to your email.

P.M. (personal message function on this site) me the model number please if you request this, post your email to me in the p.m. and I will email you the pdf.

I also have extra valves all over the shop.

Happy Camping, Safe Trails.

Harry Young is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suburban hot water heater anode difficult to install Steve M. Problem Solving | Owners Helping Owners 7 05-25-2009 07:22 PM
LP Gas Valve Help!! for an old Suburban convection David Jack Problem Solving | Owners Helping Owners 6 02-15-2009 08:30 PM
Suburban Heater...What am I missing??? Steve B Problem Solving | Owners Helping Owners 8 01-01-2009 08:51 AM
SUBURBAN sw6p WATER HEATER gary g Classified Archives 0 07-06-2008 08:08 PM
Water heater trouble shooting (Suburban 6 gallon) Legacy Posts Problem Solving | Owners Helping Owners 12 02-14-2003 10:06 AM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:49 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.