Trailer Blinker Issue - Fiberglass RV



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-10-2019, 06:53 AM   #1
Member
 
Name: William
Trailer: Scamp
Lakeville, CT
Posts: 99
Trailer Blinker Issue

Looking for some ideas here. Used the Scamp for the first time this season and did the customary light check before pulling out and the right side blinker and brake light do not work on the Scamp. TV has led indicators on the 7-way outlet and they are not firing there either. Left side works fine on the trailer and TV outlet. TV has all the proper lights.

The setup is a Curt converter box with T connectors to intercept the signal to the TV tail lights and independent power that runs straight to the battery. I checked the blinker signals in to the converter and it seems fine on both sides. Alternating 0-11.5 V with the blinkers. On the output side of the converter I see alternating 0-11 V for the left blinker and more like alternating 5-9 V on the right. The converter box has a ground wire direct to the body and it seems good. Iíve taken a look at the wiring and donít see potential for a short and donít see how a short would produce this behavior in any case. Could it just be a bad converter box?

One solution I thought of was if I replaced the TV and trailer bulbs with LEDs maybe the current would be low enough that that they would all run fine direct from the TV system without need for converter box. Otherwise, just replace converter box. Iím at a campground but have some basic tools and a Napa 2.6 miles away.

Thanks for any thoughts.

Bill
__________________

biw314 is offline   Reply With Quote
Old 07-10-2019, 07:10 AM   #2
Senior Member
 
Name: Gordon
Trailer: 2015 Scamp (16 Std Layout 4) with '15 Toyota Sienna LE Tug
North Carolina
Posts: 3,251
Sure does sound like the converter is shot. What is the make and model? Age? Maybe call the manufacturer for troubleshooting tips or advice. You could maybe swap the left and rights to make sure the problem is not with the trailer.
__________________

gordon2 is online now   Reply With Quote
Old 07-13-2019, 10:13 AM   #3
Member
 
Name: William
Trailer: Scamp
Lakeville, CT
Posts: 99
Solved

Got a converter and wired it up for just the right blinker and still no good. That caused me to investigate further and found a bad wire up under the bumper cover. Just rotted out from the inside! Never seen that before. Fixed.
biw314 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Left blinker not working on 19ft 1979 bigfoot theburro Electrical | Charging, Systems, Solar and Generators 14 07-20-2016 08:12 AM
Left blinker not working on 19ft 1979 bigfoot theburro Problem Solving | Owners Helping Owners 4 07-18-2016 09:22 PM
Dual mode LED blinker side marker lights GregLS Electrical | Charging, Systems, Solar and Generators 4 06-09-2014 03:23 PM
Blinker Randomly Works barryra Problem Solving | Owners Helping Owners 8 08-27-2012 09:29 PM
lens cover for '84 Burro blinker Leslie L. Problem Solving | Owners Helping Owners 5 09-20-2006 11:14 PM

» Upcoming Events
No events scheduled in
the next 465 days.
» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.