SHURFlo water pump - Fiberglass RV


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-11-2016, 12:36 PM   #1
Senior Member
 
reeves99's Avatar
 
Name: Philip
Trailer: Escape 13 /Hyundai Santa Fe
British Columbia
Posts: 472
Registry
SHURFlo water pump

My pump is making growling noises and the water pressure is weak. I checked and there's no bear or other wild animals in the pump that would growl.
Any suggestions as to the cause or cure?
__________________

__________________
It's not the size.....
reeves99 is offline   Reply With Quote
Old 06-11-2016, 01:30 PM   #2
Senior Member
 
Name: Gordon
Trailer: 2015 Scamp (16 Std Layout 4) with '15 Toyota Sienna LE Tug
North Carolina
Posts: 1,885
Quote:
Originally Posted by reeves99 View Post
My pump is making growling noises and the water pressure is weak. I checked and there's no bear or other wild animals in the pump that would growl.
Any suggestions as to the cause or cure?
Well, my first step would be to follow the troubleshooting guide in the manual... esp the section, "NOISY OR ROUGH OPERATION"
http://shurflo.com/images/files/RV_P...s/911-1024.pdf (Might not be the manual for your model)
__________________

__________________
gordon2 is offline   Reply With Quote
Old 06-11-2016, 01:54 PM   #3
Raz
Senior Member
 
Raz's Avatar
 
Name: Raz
Trailer: Trillium 2010
Vermont
Posts: 4,056
When mine stopped working I took it apart. I found a small piece of waste plastic that was stopping the diaphragm from operating properly. I removed it and put things back together. Pumps still working fine. I added a strainer to eliminate the problem happening again.
__________________
Raz is online now   Reply With Quote
Old 06-12-2016, 11:18 AM   #4
Senior Member
 
reeves99's Avatar
 
Name: Philip
Trailer: Escape 13 /Hyundai Santa Fe
British Columbia
Posts: 472
Registry
Thanks for the suggestions. I took off the inlet and outlet pipes. No blockages. When the pump was re-priming it sounded fine. Then the noise started again. Hmmm.
So I checked the filter on the tap. And guess what? It was clogged. It's a goofy sort of multi-part filter, and until you take it apart you can't see the gunk in there. But I got it apart and cleaned out. And voilà. The pump runs fine now.
And what possible use is that stupid tap filter for anyway? Sheesh!
__________________
It's not the size.....
reeves99 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding shurflo water pump to sink. ?? AKSCAMP Modifications, Alterations and Updates 3 04-25-2016 02:56 PM
Plumbing in a Boler with Shurflo Pump VIDEO kevin61 Problem Solving | Owners Helping Owners 4 07-24-2008 11:38 AM
Shurflo Strainer for Water Line efawcett Problem Solving | Owners Helping Owners 8 08-02-2007 05:53 PM
SHURflo Comfort Air fan? Julia O. Modifications, Alterations and Updates 6 05-18-2007 08:40 AM

» Upcoming Events
No events scheduled in
the next 465 days.
» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.