Scampfire - Fiberglass RV
Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-11-2020, 11:11 AM   #1
Junior Member
 
Name: Steve
Trailer: Scamp 13
Wisconsin
Posts: 8
Scampfire

We just picked up our 2013 Scamp 13 last weekend. Its in great shape but has not been used much ever. That said it needed some maintenance that had not been done in years. The heater would stay lit so I cleaned out the intake which was full of mud from wasps and fixed that. The water tank flame was not blue but a lazy orange so I cleaned that and now that works. Fridge propane pilot would not stay lit so cleaned the burner. Looking at the diagram, the burner jet may be missing. I don't think it was not on the end of the gas pipe unless its firmly attached there. It did not appear to be in the burner. There were bug parts in there though and I cleaned all that out and reassembled everything.

I turned the control to high like the instructions say and tried to light with the electric piezo but it would not light but I was able to get the pilot to light with a flame. Stopped pushing down on the control and it stayed lit. Success! Or maybe success. I heard the sound of gas hissing. Seconds later flames were coming out of the vents above the vent you open to access the fridge controls. I quickly ran to turn of the tank and the flames went out.

Any idea what would cause this? We are heading out this evening to camp with our new Scamp and I am wondering if its safe to use the stove and heater?

Thoughts?
Schwetzel is offline   Reply With Quote
Old 09-11-2020, 12:43 PM   #2
Raz
Senior Member
 
Raz's Avatar
 
Name: Raz
Trailer: Trillium 2010
Vermont
Posts: 4,881
If it's the 1.9 ft^3 Dometic rm2193, the orifice is a small cup shaped disc about 3/8 " in diameter with a very small hole that gets cleaned with alcohol only. If it fell out then gas would fill the chimney and boom. A search on line should yield a manual with a diagram.
Raz is offline   Reply With Quote
Old 09-11-2020, 01:07 PM   #3
Junior Member
 
Name: Steve
Trailer: Scamp 13
Wisconsin
Posts: 8
Scampfire

That sounds exactly like what I am thinking the problem is after digging into it. As I could not find that part when I cleaned things out I thought that might be the issue. Thank you for responding!
Schwetzel is offline   Reply With Quote
Old 09-11-2020, 01:18 PM   #4
Raz
Senior Member
 
Raz's Avatar
 
Name: Raz
Trailer: Trillium 2010
Vermont
Posts: 4,881
Part L in the diagram is the orifice.

Click image for larger version

Name:	_20200911_151705.JPG
Views:	5
Size:	29.6 KB
ID:	137390
Raz is offline   Reply With Quote
Reply

Tags
scamp


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Trailer Showcase

Scamp

Gilda

Wiffle

ednpat3
» Upcoming Events
No events scheduled in
the next 465 days.
» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.