Electrical problems centurion 1979 - Fiberglass RV
Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-01-2021, 02:09 PM   #1
Junior Member
 
Name: Jimmy
Trailer: Centurion
New Brunswick
Posts: 1
Electrical problems centurion 1979

Hi everyones! Last summer i went to camping for a weekend and in the night something has stop working properly and i dont know what it is 🤔 my fridge plug, my kitchen plug and the outside plug does not work anymore i only got one plug left for all my camping trailer. I got a 1979 centurion an9d the converter is a powertron RM 300D 30 amp i dont know what to do and the breaker didnt shut off , i checked everythings but dont seem to find the problems hehe 😅 so if someones can help me with that , it would be awesome !! Thank you !! ( and ya if you tcheck on the pitcure i put all the breaker off for precaution for me hehe )
Attached Thumbnails
20210501_153715.jpg   20210501_153712.jpg  

20210501_153710.jpg  
Xjimx007 is offline   Reply With Quote
Old 05-02-2021, 11:35 AM   #2
Senior Member
 
Name: Michael
Trailer: Trail Cruiser
Alberta
Posts: 747
Jimmy, I'm not familiar with your unit but I am familiar with your problem. As I understand it, you have lost power to 3 of your 4 electrical (120volt?) receptacles?
The first thing I would check would be the breakers/fuses. With the power turned off, turn each breaker off and then on again. Pull each fuse and check it. Replace fuses as necessary.
Have someone else connect power to your unit while you watch the breakers/fuses to see if any of them trip, which will indicate the problem circuit. Trace the circuit downstream of any tripped fuses/breakers.
If no fuses/breakers trip, use a test light to check each fuse/breaker for power. If no power to one or more fuses/breakers, trace the circuit upstream to find the source of the problem.
As one of your 4 receptacles is still live, this should identify your problem.
Mike_L is offline   Reply With Quote
Old 05-02-2021, 11:59 PM   #3
Senior Member
 
Name: Charles
Trailer: Bigfoot
Georgia
Posts: 111
The round white button circuit breakers on the far right are for the 12v dc system and HAVE NOTHING TO DO WITH YOUR PROBLEM. If you do not have power from the household type 120v receptacles, it has to be one of those two 15 amp circuit breakers next to the 30 amp main on the left side.

There could be a GFCI tripped somewhere, or the breaker could have lost contact internally. Have you cycled them on and off a couple or three times?

Trailers tend to have loose connections due to it experiencing a rolling earthquake going down the road all the time. With all power disconnected you need to check the screws on the breakers to make sure that they are tight, you may need to remove and reinstall the breakers or replace them.

I edited by original post a few minutes after I posted it. I did some research and found that the ITE type BL circuit breakers are a bolt on type and not a push on over the stab type. There is a Siemens breaker that is interchangeable, as Siemens bought out ITE many years ago, but an electrical house would probably have to special order it. Bolt on breakers are not very common nowdays.

Amazon listing for a 15 amp Siemens type BL bolt on breaker but the pic shows a 20 amp

Charles
__________________
'03 Ram 2500 CTD and 2008 Bigfoot 25B21RB.. Previous, Being repaired and will be sold, is a 2008 Thor/Dutchman Freedom Spirit 180. SOLD - 2007 Winnebago View 23H Motorhome.
CharlesinGA is offline   Reply With Quote
Reply

Tags
electrical


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 13' Scamp Centurion 3000 toast/replacement jefflarsen Electrical | Charging, Systems, Solar and Generators 11 05-01-2017 09:45 PM
centurion 3000 in 16' scamp jcassady Electrical | Charging, Systems, Solar and Generators 6 09-25-2015 09:03 PM
Electrical problems with a 1979 Jubilee Trillium Leonard31 Electrical | Charging, Systems, Solar and Generators 9 05-24-2014 03:29 PM
Centurion 3000 Converter issue: flickering lights on DC power Shannon Thompson Care and Feeding of Molded Fiberglass Trailers 1 01-27-2013 07:45 AM
Electrical Problems 1979 Beachcomber Ralphie Problem Solving | Owners Helping Owners 8 06-27-2009 03:46 PM

» Upcoming Events
No events scheduled in
the next 465 days.
» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:07 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.